Note: This web site is only kept up to date for OSG Software 1.2 (VDT 2.0.0). If you are looking for information for the most recent release, the RPM-based OSG Software 3.0, please see the OSG documentation web site

Globus 2.2 vs. Globus 2.4

We are working hard to provide you with the latest versions of individual packages in VDT. The version of Globus Toolkit in the VDT 1.1.12 is 2.2.4. VDT 1.1.13 has Globus 2.4.3, plus patches. We in the VDT team are committed to make this transition to new Globus for you as smooth as possible. An important question for people that may use grids that contain both Globus 2.2 and 2.4: how compatible are they?

New features of Globus 2.4

Different proxy formats

Globus 2.4 supports two types of proxy format. The old Globus proprietary format and the format which is more generic, standardized and will be supported by future versions of Globus. By default, Globus 2.4 will use the old proxy format, so you do not need to worry about the new format.

If you want to create a proxy in the new format, which is supported by Globus 2.4 onwards only:

grid-proxy-init -new

Note that Globus 3.0 and later use the new format by default, so if you want to use Globus 3.0 to talk to a Globus 2.x installation, you will need to create your proxy with the -old flag:

grid-proxy-init -old

Compatibility of job submission

In our tests, there are no problems submitting jobs from Globus 2.2 to Globus 2.4 or vice-versa, as long as you use the old proxy format.

Compatibility of MDS

Yujun Wu from Fermilab has done a detailed analysis of compatibility of MDS 2.2 with MDS 2.4. The short answer is that there are no problems with compatibility. If you would like to read the details of his tests, there are three documents: